CISCO по русски. Набор статей


Конфигурация динамической трансляции



Конфигурация динамической трансляции

Для конфигурации динамической трансляции необходимо выполнить следующие действия:

Действие Команда
Определить пул глобальных адресов ip nat pool <имя> <первый адрес> <последний адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить стандартный список доступа, регламентирующий адреса, подлежащие трансляции access-list <номер> permit <адрес или блок адресов>
Установить динамическую трансляцию на основе списка доступа, определенного на предыдущем шаге ip nat inside source list <номер списка доступа> pool <имя>
Указать внутренний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети ip nat inside
Указать внешний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети ip nat outside
 

Замечание. Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

Представленный ниже пример транслирует все адреса узлов-источников, определенных списком доступа 1 (разрешены адреса от 192.168.1.0/24), в пул адресов, названный net-208. Этот пул содержит адреса с 171.69.233.208 по 171.69.233.233.

ip nat pool net-208 171.69.233.208 171.69.233.233 netmask 255.255.255.240

ip nat inside source list 1 pool net-208

!

interface serial 0

ip address 171.69.232.182 255.255.255.240

ip nat outside

!

interface ethernet 0

ip address 192.168.1.94 255.255.255.0

ip nat inside

!

access-list 1 permit 192.168.1.0 0.0.0.255









Начало  Назад  Вперед