CISCO по русски. Набор статей


Конфигурирование динамической трансляции



Конфигурирование динамической трансляции

Для конфигурирования динамической трансляции внешних адресов узлов-отправителей, необходимо выполнить следующие шаги:

Действие Команда
Определить пул локальных адресов ip nat pool <имя> <начальный адрес> <конечный адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить стандартный список доступа access-list <номер> permit <локальный адрес или блок адресов>
Установить динамическую трансляцию внешних адресов узлов-отправителей, основанную на списке доступа, определенном на предыдущем шаге ip nat outside source list <номер списка доступа> pool <имя>
Указать внутренний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети ip nat inside
Указать внешний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети ip nat outside
 

Замечание
Замечание

Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

В приведенном ниже примере адреса в локальной сети используются кем-то еще в качестве легальных адресов Интернет. Во внешней сети необходимо производить дополнительную трансляцию. Пул net-10 является пулом внешних локальных адресов IP. Выражение ip nat outside source list 1 pool net-10 транслирует адреса узлов из внешней перекрывающейся сети в адреса данного пула.

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28

ip nat pool net-10 10.0.1.0 10.0.1.255 prefix-length 24

ip nat inside source list 1 pool net-208

ip nat outside source list 1 pool net-10

!

interface serial 0

ip address 171.69.232.192 255.255.255.240

ip nat outside

!

interface ethernet0

ip address 192.168.1.94 255.255.255.0

ip nat inside

access-list 1 permit 192.168.1.0 0.0.0.255









Начало  Назад  Вперед