CISCO по русски. Набор статей


Рисунок 4 Распределение нагрузки ТСР



Рисунок 4. Распределение нагрузки ТСР

Маршрутизатор выполняет следующие действия при переборе адресов:

  1. Пользователь узла В (9.6.7.3) открывает соединение с виртуальным узлом 1.1.1.127.
  2. Маршрутизатор получает пакет с запросом на подключение и создает новую запись трансляции, выбирая для нее новый реальный узел (1.1.1.1) в качестве внутреннего локального адреса IP.
  3. Маршрутизатор заменяет адрес назначения выбранным адресом реального узла и передает пакет.
  4. Узел 1.1.1.1 получает пакет и формирует ответ на него.
  5. Маршрутизатор получает ответный пакет и просматривает таблицу NAT, используя в качестве ключа поиска внутренний локальный адрес и номер порта. Маршрутизатор транслирует адрес источника в адрес виртуального узла и передает пакет по сети.

Следующий запрос на соединение вынуждает маршрутизатор выбирать адрес 1.1.1.2 в качестве внутреннего локального адреса.

Для конфигурирования этого режима использования функций NAT необходимо произвести приведенные ниже шаги. Эта функция NAT позволяет устанавливать соответствие между одним виртуальным узлом и множеством реальных узлов сети. Каждая новая сессия ТСР открывает новый виртуальный узел. Эта сессия будет транслироваться как сессия с другим реальным узлом.

Действие Команда
Определить пул адресов, состоящий из адресов реальных узлов ip nat pool <имя> <начальный адрес> <конечный адрес> [netmask <маска подсети> или prefix-length <длина префикса>]
Определить список доступа, разрешающий адрес виртуального узла access-list <номер> permit <адрес назначения или группа адресов>
Установить динамическую внутреннюю трансляцию адресов назначения на основе вписка доступа, определенного на предыдущем шаге ip nat inside destination list <номер списка доступа> pool <имя>
Указать внутренний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внутренней сети ip nat inside
Указать внешний интерфейс interface <тип> <номер>
Пометить данный интерфейс, как принадлежащий внешней сети ip nat outside

Замечание
Замечание

Список доступа должен разрешать только те адреса, которые действительно необходимо транслировать (Необходимо помнить, что последней строкой любого списка доступа является deny all). Список доступа, разрешающий более широкий блок адресов может привести к непредсказуемым результатам.

В приведенном ниже примере основной целью определения виртуального адреса является то, что все соединения распределяются между несколькими реальными узлами. Пул адресов определяет эти узлы. Список доступа определяет виртуальный адрес. Если в данный момент нет процедуры трансляции, то пакет ТСР с интерфейса Serial 0 (внешний интерфейс), адрес назначения которого удовлетворяет условиям списка доступа, транслируется в один из адресов адресного пула.

ip nat pool real-hosts 192.168.15.2 192.168.15.15 prefix-length 28 type rotary

ip nat inside destination list 2 pool real-hosts

!

interface serial 0

ip address 192.168.15.129 255.255.255.240

ip nat outside

!

interface ethernet 0

ip address 192.168.15.17 255.255.255.240

ip nat inside

!

access-list 2 permit 192.168.15.1









Начало  Назад  Вперед